New version of the App is unusable on Samsung Tab A

I have had an absolutely miserable experience trying to use the new version of the app on a fairly new Galaxy Tab A. As other have noted it can be very unresponsive but worse yet for me, most of the time it won’t even load. Gets stuck at the the welcome screen or an all white screen.
It can’t be that hard to make an app work properly, PLEASE fix it.

When it does work it is great, but I am ready to give up on it.

Tagging @MusopiaApps @Musopia for any assistance you may be able to give here.

Cheers :smiley:

| Richard_close2u | JustinGuitar Official Guide

@MyTurn Thank you for letting us know about the glitches.
Could you please send us more info about your device model and operation system via so we can assist you better?

I have same device. It is quirky on loading. I literally just keep tapping the first image and it eventually opens. Once opened, it functions fine. So…i try not to close it cuz i’m afraid one of these times it won’t open. Lol

Thanks for the tip, that seems to help on my Tab.

I responded to your rep “Danna” via email, here is the transcript:
Hello, to answer your items:

1 - Galaxy Tab A SM-T510, Android ver 11

2 - Yes, many many times

3- Yes, many many times

4 - Tried this suggestion, no effect.



##- Please type your reply above this line -##

Your request (34432) has been updated. To add additional comments, reply to this email.

\ 40x40 Musopia Support Team (Musopia)

Mar 15, 2022, 10:56 GMT+3


Thank you for reaching out. Sorry that the app is not performing well on your device.
Could you please answer my questions below?

  1. Please confirm your device model and operating system
  2. Have you tried rebooting the app (closing it and opening it again)?
  3. Have you tried rebooting the whole device?
  4. You can also try to clean Google Play cache:
  • Go to Settings on your Android device.
  • Tap on Apps & notifications options.
  • Here, try searching for Google Play Store and tap on it.
  • Tap on Storage option.
  • Now tap on Clear Storage and Clear Cache buttons one by one. This will clear data and cache for your Google Play Store.

Let us know how it goes.

Musopia Support Team


I appear to be having the same issue getting teh app to start with my Samsung Galaxy S6 tablet

It was all working fine and now - presumably after an app upgrade - it sits on teh opening phot screen and eventually tells me that it is trying to connect to the server and to check my internet connection - which is fine for other apps on the tablet.

I have followed the advice below
Deleted and reloaded teh app
cleared every cache under the sun
restarted teh device many times

  • but no joy

Help please!!


Hello Jim @jimali , could you please help and record your screen starting from launching the app and send the film to us via
Have you tried the tip from Karende, to keep tapping the first image? Did it work on your Tab?

Best, Musopia Support Team

I have a huawei Matepad 10.4 and a DooGee Android 10 phone. The Justin Guitar app runs clunkily on the phone and will not open past the blue picture of Justin on the tablet. This is an expensive monthly subscription app. Please advise me on how to make it run smoothly on my phone or actually run on my tablet… Or I would like a refund.

Regards, Laurence Swain

This issue still exists in the current version of the app on both a Pixel 6 Pro and a Samsung Galaxy Tab S7. The app is stuck on the loading screen and will only open once every 10 times (sometimes more attempts of force closing the app are necessary).

Rebooting, restarting the app and even reinstalling don’t really make a difference. It is not that hard to reliably get an app behind it’s splash screen. For now my subscription is paused which is a shame as the app itself ist great if it starts up.

Same here on a Galaxy Tab S6, it most often won’t get past the Musopia loading screen (hangs on ‘igniting 100%’). Every now and then it does continue, but that still takes a LONG time.

Also once had that the microphone kept staying open after exiting the tuner section (indicated by a small green led on the S6)

Pretty bad experience so far unfortunately…