No Sound From Backing Track Played through OBS (and on to Zoom)

Not sure if anyone will have any answers here but I’ll give it a punt.

In preparation for the up and coming Open Mic (27 hrs away !) I created a percussion track in GuitarPro and exported it as an MP3 and WAV file, to use a backing track while I record in OBS or feed into Zoom. Using the prescribed method of having background music playing as I “stream” I added a Media Source to the OBS Scene in order to play the BT.

As can be seen from the screenshot below, there is a healthy signal being picked up by OBS.
The Media Source is set to Monitor and Output in Adv Audio settings but I am getting no sound. I have tried this with both the the MP3 and WAV version to no avail and also tried using the VLC capture, as recommended on some OBS forums. Again I can see the sound but can’t hear it.


What I did use successfully (initially) was the Application Audio Capture which is still a beta release and captured the BT via Windows Media Player and all was good. After much faffing around I still could not get sound from Media Source or VLC.

Although Application Audio Capture seemed to be working and the backing track ran parallel to my playing, when I replayed the recorded video the percussion and guitar were suddenly out of sync. :angry: So gave up on the idea of running a BT on OBS as a bad job.

If anyone had any thoughts or solutions feel free to chip in but I won’t test them until the OM has been and gone.

As with most things in life there was a perfectly acceptable work around. I dragged out and dusted down my trusty DigiTech JamMan looper, fired up JamManager on the PC and uploaded the BT onto the Looper, as I have done a few times in the past. JamMan was then plumbed into the AI and a fully synced OM rehearsal was duly recorded. :smiley_cat:

So no last minute OM dramas (yet :rofl: ) but I’d be interested to know if anyone has used the Media Source option in OBS while playing (via Audio Input Capture or ASIO IC) and if so HOW !


Hey Toby, let me share some of how I now use OBS that may or may not help.

I always turn on display of ‘Audio Monitor’ which you will find under the ‘Docks’ drop-down menu.

You will notice a settings cog on the left hand side, centred next to the meters. Click that and you’ll notice an ‘Outputs’ option on the pop-up menu. You can use this to set up different ‘Tracks’ in OBS to route to different output devices.

When you pop up ‘Advanced Audio Properties’, you’ll see the 6 available ‘Tracks’ on the right hand side, with the option to select for each ‘Source’.

So I no longer use the ‘Monitor’ function. That is set to ‘Monitor Off’. I achieve monitoring by selecting which ‘Track’ is enabled for each ‘Source’ in ‘Advanced Audio Properties’ and what the ‘Output’ device is for each ‘Track’.

Perhaps exploring that will resolve your issue of hearing nothing despite meters indicating sound received on the Source.

As for latency, I found when I started to mix in audio from the Trio, that it required a 50ms ‘Sync Offset’ to ensure video, guitar, and Trio were in sync. I received no comments about anything being out of sync after sharing the Before You Accuse Me video after the last OM, and assume somebody would have called it out if they’d picked up something.

Now resist all urge to tinker before the OM. Or I shall have to float the idea of extending your naming to be Toby Tinker-Man Madman Jenner :rofl: Not bad channeling as the last person who earned that Moniker was Claudio Raneiri in the season he led Leicester City to the Premiership title :rofl:

Thanks for the reply David.

I have the Audio Mixer (monitor) set up as one of the default displays, so it “auto docks” so to speak.

Wondering if you may be on to something, as I just left the track settings as default, which is all 6 selected. Wonder if that is causing some conflict ? So I’ll maybe have a play later and just assign a couple of tracks to each input - ignore the Live Cam as the webcam mic is disabled in Windows audio settings.

I’m trying to save my voice for this evening so won’t do more than a couple of dry runs this afternoon but the trusty JamMan is doing what I need for now. But it would be good to solve this issue…just to limit the number of boxes on the floor at show time :rofl:

I take it you are assigning the Trio as an OBS input source ? I plug mine into the Xenyx or 1820, so OBS get one combined audio input. 50ms sounds about right though, so thanks for that. Minimal tinkering as I’ve encountered the Ranieri experience at WFC ! :rofl:

Will let you know how it goes.


1 Like

Some reading for when I get back this am.

1 Like

Have a look at how the Outputs are configured on that cog in the Audio Monitor. I think, not sure, that by default tracks 2-6 may not be configured. When you click on an track in Output you first have to select ‘Show’ on the menu which displays the track on the monitor. Then you can go in a second time and select an output device.

Yup. That was my reason for the upgrade from my trusty Focusrite 2i2 to the Behringer UMC404HD. I use the amp output of the Trio plugged into input 3 on the 404 and select input 3 on the UMC ASIO Driver in OBS

1 Like

Thanks for the input but I don’t think the track set up is the issue. I’m likely to be on a different version of OBS to you, as I rolled back to V28 after the ASIO4ALL issues I was having, so seeing different menus.
And as an aside neither ASIO4ALL or FlexASIO seem to be functioning at the moments, so the AI is going in as a plain old Audio Input Capture and working fine - step away from the dial !

The only way I could get to hear the Media Source audio was to change the Audio Advanced Monitoring Device to the Xenyx, then it came through fine. But it is mute when using the Virtual Cable to send the OBS audio/video to Zoom. But the sound does appear on the video recording on playback. That is with Monitor & Output set that is supposed to allow you to hear the audio track in realtime and whatever track I configure. And yes the “master” track setting was only set to track 1 for recording. Even when I brought Zoom up, where I suspected to hear the Media Source audio in the meeting there was still nothing but again the green level on the mic icon was bouncing up and down quite happily !! ?? !!
Think’ll be sticking with the JamMan !!

Anyway that’s enough tinkering for today. Set up has been re stabilised for pm rehearsals and its time for a little fingerstyle practice.

I’ve not read all of the thread but I noticed that you have had to roll back your OBS install Toby because of the ASIO4ALL issue. I had this as well and ended up downloading from the link below and it solved my issue of Reaper and OBS not chatting to each other.

Hope this helps.



Thank Stefan.

I was already set up with OBS-ASIO 3.1.1 loaded and Reaper OBS comms via ReaRoute was working fine. This was just the Media Source audio not being sent to Zoom. So ok If I want to record just in OBS and set the AI as Monitoring Device, just not when Zoom is in the equation.

The JamMan did its job on the night, so might just stick with that for future BTs.


1 Like

Ahh, okay, cool. That’s what I get for not reading the whole thread isn’t it. :smiley: I’ll graciously bow out as I cannot help you with your issue.

1 Like