Odd channel audio in the recent Christmas Bash

Justin actually mentioned it live when I came in the Streamyard studio that vocal was left channel and guitar was right channel. We went with it any way but I have looked back and although there were various technical issues that cropped (honestly not that many for the number of pieces of gear and option folks were throwing at Streamyard) I think I may have been the only one with this issue and I’m curious. in my short soundcheck with Justin I don’t remember this being an issue. (hold that thought).

My setup:
Focusrite 2i2 with a dynamic mic on vocal and a condenser mic next to a Spark Amp for guitar. The 2i2 goes into OBS for all the audio and OBS controls the video from my webcam and all that goes into Streamyard

Streamyard settings:
OBS virtual camera is started first
Unmute, Streamyard turn on camera.
Here is an image of the settings:


No other speakers on and my headphones are in the 2i2 now so practically my speaker is my headphones.

I don’t think I clicked Stereo on during the sound check. While I was watching others sound check it seemed like I had mono so I clicked Stereo on and that sounded better.

Next time I’m live and get the separated channel thing and go.

Do you think my clicking the stereo on did that? Thanks for any thoughts on it…Rod

Hi Rod, I don’t think you were the only one. I do recall someone playing before you where the vocal was coming through on my left and guitar on the right.

Rod, needless to say, I am not that familiar with StreamYard. That said, if that is an image of the settings you had when entering the studio, then it looks like StreamYard was set up to receive audio from your 2i2, not from OBS.

As far as I understand, perhaps other OBS users performing at the event can confirm, you would need to set up the virtual cable on your computer, direct the OBS monitor output to the virtual cable, and set StreamYard audio input to be the virtual cable.

Now I am not sure how StreamYard would handle the two inputs that are provided from the 2i2 via USB. It may be that it defaults input 1 to a left channel and input 2 to the right channel. Note that I am guessing. But I seem to recall seem people experiencing that sort of behaviour before.

I am not sure exactly what the stereo setting does in StreamYard. If I understood correctly, and that is tricky as I was only listening in the green room and interacting via chat, Justin turned stereo on and that resolved the issue of his voice coming only through the left channel. I have no idea of his full setup and he’d be running on a Mac which may also have its own unique quirks.

I suggest you make some test recordings in StreamYard. You could start by just selecting your webcam and 2i2 in StreamYard. Based on what I think you are doing now, using OBS is not absolutely required. As Keith (@Majik) wrote in another Topic today, you only require OBS if you want to mix multiple audio inputs or cameras into a recording or stream. I think since you stopped using the app as backing, your setup is now simply a webcam plus audio from the 2i2 with the two mics plugged into it.

If that routes the 2i2 input channels to either left or right, then you could try adding OBS and feeding the webcam and 2i2 into OBS and from OBS to StreamYard via the virtual camera and cable. You have a number of options in OBS to setup your audio from 2i2 depending on the input type you choose.

Long wall of text there, hope it makes some sense, is not all nonsense :grin:

1 Like

Hi Rod it’s because you had stereo ticked off it made one channel left and the other right. If you tick it off both channels will be converted to mono and will be playing in both cans (which I find super confusing how it’sc alled here). I think Mal had something similar going on too. On zoom its by default ticked off hence you never had this probably. All the best


Hi Adi, my setup was guitar and vocals to mixer, to 2i2, to Stream yard, Was the sound odd on your end?

Sounded good to me Mal.

1 Like

Adi maybe I should update the guide. The screen grab showed Echo, Stereo and Auto all unselected but in the text I only stated Echo should not be enabled.


1 Like

No it all sounded good Mal, you just had guitar on one side of the headphones and vox on the other rather than both mixed together. Technicalities :wink:

@TheMadman_tobyjenner it’s those pesky performers going off script……again!..Rod

1 Like

For @Rod58 and @Malz - the 2i2 puts channel 1 into left and channel 2 into right if using normal Windows audio - which is what happened here.

So like adi says you need stereo disabled so they’re blended as mono to both channels.


Ahh, ok, these things sometimes pass me by, thanks for the info.

Thanks JK, Next time will hopefully be better.

Thanks Toby. I had thought the sound was ok, but had not looked at the mono stereo. So many other things bouncing around in my head prior to showtime.

1 Like