Open Mic Tech Talk - Got no sound in Zoom when using OBS? How to fix

Scenario: You’re setting up for a JGC Open Mic, and using OBS (and potentially a DAW). Sound is getting to OBS but not making it to Zoom! What could it be?

It was probably working fine before… and now it’s not! Like the magical PC gremlins stepped in and decided to cause chaos with your OM setup. It feels like you haven’t changed a thing…

if you don’t follow those acronyms, this post is probably not for you :wink:

The problem: OBS’s buggy audio loop detection

OBS has a quirk that I’ve run into, it seems undocumented but I found references to it on the OBS forum. It tries to prevent an audio loop by silencing its monitoring output in certain situations, and seems to happen to people that use OBS the way we do for livestreaming. I think OBS’s audio loop detection is buggy and is triggering. I haven’t spent time investigating all scenarios… however, this is how I have solved it, and it consistently works for me now. I think it will fix it for you if it happens again… hopefully it does.

What causes it? OBS thinks the microphone device set for your DAW input/reastream device is causing an audio loop. So we need to make sure it’s not.

How to fix

Basically (generic instructions same applies to PC/Mac). Assuming you’ve already followed Toby’s guide!:

  • Set computer’s operating system audio output to the speakers you’re going to use in the zoom meeting
  • In OBS set your monitoring device to blackhole / vb audio virtual cable (depending on which one you’re using)

  • Make sure you’ve set your advanced audio properties properly - the “audio monitoring” settings and the webcam/mic being muted are the key bits.

  • In OBS, your reastream source always has a device associated with it. Ensure it’s a microphone that is a different device than you’re using for Zoom (i.e. not your focusrite). Make sure it is definitely not blackhole / vb audio cable. This is the critical bit! This is what causes the muting. But it’s important to set everything else as well, because if you - for example, change your PC audio output to something else, it can trigger the muting.

  • Mute that microphone in your operating system, not in OBS. Otherwise the sound will get mixed when you perform (reastream & the actual mic will get blended, yuck).
  • Quit OBS and open it again. OBS needs that done to it to unmute, if it thinks it detects a loop and mutes the monitoring output. A reboot is not required, just quit and re-open.

Tada, working audio. Assuming everything else is OK!