Personal data consent

I’m still getting this on a regular basis when opening up the JG website even if I’m already logged in. Very annoying.

1 Like

@sairfingers
Gordon, I’ll push this to the team. As I understand, you access the website using your phone. Please confirm the OS and browser (maybe it is relevant).

I personally don’t experience this on my PC, so quite possibly it is specific to the way you access and maybe even personal config settings on your phone (all of which is beyond me).

1 Like

That’s an iPhone screen. I run a free content blocker called Hush that blocks pop ups like that. Just been testing it, if I turn Hush off I get the pop up and if i re enable it then I don’t

If you ever suspect that Hush is getting in the way you can quickly disable for just the page you are on

Tap the AA at the top left of the url bar and then pick turn off content blockers

1 Like

Hi David I have the issue with both my iPhone OS 16.1.2
and my iPad OS 16.2
Both devices access the internet using the Apple Safari browser.
I’ve tried clearing my browsing history which works for a while and then the pop up starts again.
After I fill in the details on the pop up I’m taken to the home page which recognises me. If it recognises me why does it keep asking for consent permissions?
I’ve just filled in the form again and am taken here


and as you can see it knows who I am.

Thanks Gordon. Beyond me to understand why that is happening. I have emailed the team but not seen any reply yet (not the best time of year, I suppose). Will add the device details.

1 Like

Hey Gordon, I use iPhone as well and never see that pop up. Could be because GDPR doesn’t apply in Australia…

But a thought - is Safari in private browsing mode? It looks like it might be from the dark address bar and light top bar. Tap the double squares, and then there is a bit down the bottom of the screen that will either say “X tabs” or “Private”. If it’s on private, switch it out of private mode and that might make your problem go away.

1 Like

Hi JK.
No, the Tab box is ticked.

1 Like

So weird then, I wonder why it happens to you but not to everyone.

It happens to me too on galaxy phone. I figured it may be down to settings on how to ask for GDPR consent.

Hi ,
It happened to my laptop regularly too…but I don’t think it’s happened to me since the first time you addressed this,…
Greetings,…

To me it suggests some browser cookies not being saved, or being cleared when closing the browser, or something similar.

Sairfingers, My issue is just the opposite. I WANT to get to the screen to manage cookie options and “OPT OUT” and can not get to it. The option to “OPT OUT” was never given to me when signing up on the site. I was told to erase cookies in my browser and log back in, which has not helped. Why can’t it JUST(in) be accessible to users in one of the drop down menus? Asking via the send-them-an-email link took a long time to reply. Most websites don’t make it so difficult to change consent choices. Any help from the community would be much appreciated. Thanks.