Reaper Audio to OBS Issues

Hey Guys, hoping someone more proficient than I am can help me out here. I’d like to start a side project to develop some of my more established songs from my songbook with multiple tracks but at the same time record video via OBS so I can put together something like @eric.lennon 's recent video, albeit less fancy, where I can at least show myself playing each track.

I’ve followed @TheMadman_tobyjenner 's excellent post on setting the link up between Reaper and OBS using ReaRoute. I’ve got the routing in Reaper set up ok, Master Track Routing → ReaRoute 1/ ReaRoute 2, but when I go to set up the ASIO input capture in OBS there are no options to select in OBS Channel 1 / OBS Channel 2 as per the image below. There’s literally nothing in the drop downs. I’ve searched endlessly the last couple of days but can find no solution. I’m pretty sure there’s something obvious I’m missing but am at a dead end. Has anyone else run into this and been able to fix it and can share any advice please?

Hi Mark,

I am sure someone will have this answer, I have just looked at mine and created a new ReaRoute and ASIO setup and straight away it had the options in the two dialogue boxes. I fiddled a bit but couldn’t really see why yours doesn’t have it.
I do remember I had some version compatibility problems so now I am not running the latest versions of either but I’m also running on an older Windows OS too.

I’ll be watching your progress here with interest as I recently wanted to do something similar where I incorporated a second video part with me signing a chorus backing window in window sort of thing. I was only using Reaper and OBS and wanted to edit the video in Reaper but couldn’t make it work at that stage. I was given some ideas by others on here so will go back to it but in reality I think it will come down to using a video editing software to get the best result, that just opens a whole new can of worms.

1 Like

Mark, I haven’t used rearoute. But I have used reastream to do the DAW to OBS thing. Maybe try that?

1 Like

Thanks JK, reastream isn’t part of the additional items in the Reaper download package anymore but your post made me search and I can see it separately. Will give it a go today, thanks mate :facepunch:

Mark what version of OBS are you running ? I had to go all the way back to v28 to get a stable platform.

It all went a bit squiffy late in the v29 chain and I was getting loads of grief with ASIO IC not even seeing my AI let alone Reaper !!!. After rereading @Majik similar guide, I rolled back to v28 and stayed on it since. They’ve definitely been monkeying around with the ASIO functions in recent release, so it may be worth you rolling back,

Hope that helps.


1 Like

Hi Toby, thank you, I’m on latest version which I think is 30. I only moved to Reaper last week, mainly to do this integration ironically!!

I’m going to spend a little time later today to try and figure it out and will give this and JK’s suggestions try. Will keep you posted!

Thanks for the suggestion :+1:

1 Like

If it helps at all, I’m running latest OBS and latest Ableton & Reaper and reastream has always worked fine.

1 Like

@jkahn @TheMadman_tobyjenner

Thanks both, have spent some time today and have it working taking JK’s option and using ReaStream and using sections 1, 2 and 3 of this post of yours Toby. Possibly the rollback would have been an easier solution(?) as ReaRoute does seem to be less of a faff, if it worked. Hopefully the Reaper team will sort out whatever they’re doing.

@CD02 - Craig, if you use that link above as your guide and go here to download the plugins (part of the reaplugs broader plug in so just download that) you can hopefully get it working right.

Nice one guys :+1:

1 Like

That’s why mine has been working fine then I am using V27. something :+1:


Glad to hear it Mark. :+1:

FWIW I’m running the latest version of Reaper. It was OBS from about 29.2 onwards that was causing the issues when using Rearoute, hence the roll back. Its certainly a more direct link if you can get it working. Have fun recording !


Ah I see, I misread the question but either way yes it’s my OBS version then, it’s 30.0.02. I’ll take a “not broken - don’t fix” approavh atm with the solution in play :slight_smile:

Your post on the setup was invaluable and made it pretty painless! :+1:

1 Like