Spotify playlists

I’ve downloaded the Spotify app (free) to my phone and compiled a playlist of songs that I’m learning so that I can play along. When it gets to the end of these songs it plays ‘recommended’ songs.
I don’t want this. I want to be able to get back to my songs.
There are 17 songs on my list and I’ve turned off Autoplay, but it still plays these extra songs.

Does anyone know how I can stop it doing this or get back to the beginning?

Is there an Enhance button in your playlist you can disable?

Thanks Jeff.
No there isn’t an Enhance button.
I had a quick look at your link but didn’t see anything obvious. I’ll have a closer look later.

1 Like

Is this any help?
Play the song, album, or playlist you want to hear repeatedly. Press the “Now Playing” bar once to expand the album art and the repetition controls. To loop the album or playlist, tap the icon that looks like a circle created by two arrows – the “Repeat” icon . It will turn green

get a paid subscription,free comes with ads and recommendations

@BurnsRhythm You do not have it because it (disabling ‘enhanced’) is a paid feature.

1 Like

Unfortunately not, Brian. The icon in your description isn’t showing on my version.

@LesPaulMoreRay @elevatortrim
What I want may not be available in the free version, although it says this in Spotify settings -

I’ll have a sift through @Jeff ‘s link and see if I can find anything.

This works for the paid version on iOS…maybe it will work for your configuration as well.

  1. Open one of the individual songs in your

  2. Tap the icon circled in red (note you can tap it again, and you will see a “1” in the icon, and it will loop that single song, which can also be useful)

Hi Tom, thanks.
My version doesn’t have that icon. It must be a premium feature.

I think I may have this sorted.
It’s no longer playing any extra songs and I haven’t done anything more.
My thinking is that it loads songs at the start of each cycle depending on the settings.
If autoplay is on, then it will load extra songs and will play them even if autoplay is subsequently switched off.
If autoplay is off, then it doesn’t load extra songs and probably won’t play them if you switch autoplay back on.
It seems that any changes you make mid-cycle don’t take effect until the following cycle.
I also added another song but it didn’t play until the next cycle.

Since my post a couple of days ago, things have changed on my Spotify app (with absolutely no notice or explanation…which seems to be standard practice in the software industry these days :rage: )

Now the loop function is under the “…” menu at the top right.

It still works the same way - toggling through loop playlist, loop this song, and off.

This may or may not work for you, in your region with your free subscription.

It’s working fine now without the extra songs, Tom.
I can see how a loop function would be good but it isn’t available on my version.