Unable to hear midi track in Reaper using Akai MPK Midi keyboard

I’m new to midi keyboards and new to reaper. Created a track, was able to get sounds from keyboard and pads recorded, saw the output in the level meters and on the track, unable to hear those sounds via my headphones. Any suggestions appreciated.

Just tried it in garage band and by default I can hear the midi keyboard output in my headphones.

Back in Reaper, when I enable the metronome, I can hear the metronome clicks in the playback, but none of the sounds that are in the track come through.

if your interface has an input monitoring button, try having that switched on and input monitoring in reaper switched off - or vice versa

Thanks, I don’t see any input monitoring on the midi keyboard, no mini headphone jack or such.

Have you checked the routing in the track? Make sure it is being sent to the master? Do you see output on the master meters as well.

If it is a midi track, do you have a digital instrument plugin setup to play the midi?

It sounds like it’s a controller + Reaper issue rather than a purely controller issue. I’m not familiar with Reaper, but I suspect you’ll need to configure the controller in Reaper. I found a blog post (How To Setup Your MIDI Controller With Reaper) which says some MIDI controllers don’t automatically map (i.e. configure) in Reaper and that you’ll need to do it manually, once.

Give the article a look and let me know if that helps, or not.

Wish I could offer more advice, but as I mentioned, I’m not familiar with Reaper.

I presume you’ve checked the simplest thing (that I sometimes do), and that track is not muted in Reaper?

Thanks @DavidP @J.W.C and @brianlarsen

I’ll check out the article. Called a friend and he suggested looking at the routing

The one I’m trying to sort out is the ‘midi track piano’

I can’t say I understand the routing diagram

I did install all of the akai software and noticed some of the plugins loaded when I started reaper but can’t answer more about that.

I’ve also discovered the reaper forums and may go there as well.

It’s the silly season and suddenly got busier in family matters so will plug away on this as I can.

Thanks again and Merry Xmas

Tony

May be a stupid question and that diagram might have the answer in it but I struggle with the routing boxes ! The track is set to Monitor Input ? Here it is disabled. Just a thought :sunglasses:

@TheMadman_tobyjenner Thanks. I’ve been trying to locate the pop up menu from your image. I’ve right clicked on all sorts of things but not able to find it. Any ideas?

Tony, right click on the record button of the track in the mixer. That should bring the panel up.
If Monitor Input is not ticked/selected, the midi will be muted, So if it is the same as my screenshot just click on it to enable. :sunglasses:

@TheMadman_tobyjenner yep, got it, thanks for the clarification, it was checked / selected already.

1 Like

Tony

That looks ok as I just compared to an old project.

Been a while since I used a midi track, so just fired up Reaper to check a project from earlier this year. Guess what no sound on my triple drum experimental track proforma ! Then I saw I did not have my drum FX plugin on any of the tracks (I’d been trying various vst plug-in kits) ! So added EZ Drummer and bingo, sound. So, and apologies for another stupid question, you have created midi input yes ? But have you given the track a virtual instrument for the midi to be played through ? I might be teaching you to suck eggs but I am just trying to cover all the bases and running out of ideas ! As you see its something I’ve done many times. I’ll insert a set of midi tracks from something like GuitarPro, add the usual instrument plugins, then wonder where the Hammond organ or something went, only to find I missed that one and the track had no FX !! So I am sure you have it covered but I have to ask to eliminate that as a cause.

BTW as I had to check. That Monitor Input can be off or on for midi input by the looks of it but needs to be on for DI input. So that was a red herring, my bad.

Cheers

Toby
:sunglasses:

You rock! Appreciate the help.

I know nothing about what adding an FX is supposed to do as I’m new to this whole DAW process but conceptually I get it. Added one, then a second, see below, still no sound.

Hey I’m not sure about that as you still have no sound ! What I meant was an instrument plug-in which will turn the midi “code” into sound. I see that you have Akai Pro on the track but know nothing about it bar what I just googled. Drum midi writer ? I need to see if it acts a virtual instrument as well or is just a midi recorder. Not too late here so I’ll do a quick whizz around t’internet and see if there is anything on the Cockos site. As I have Maggie’s timeline on my phone I see your day has just begun., 9ish ? So hang 10 and hasta la vista, I’ll be back. :sunglasses:

Thanks for your keen interest. Really!!!

I’ve checked out the Reaper web site and there’s a wealth of info there that I’ve not checked out yet, Xmas busyness is descending on me as well so it’s not of any urgency. I do want to research the reaper faqs and such before getting others to put too much time into it. I did follow the basic reaper faq, but there seems to be many more technical articles on their web site.

Yeah, it’s early morning here in AU

Came across a similar issue in reddit (i’m not a user!) but the guy said he got around with the info in this link
http://community.akaipro.com/akai_professional/topics/mpc_vsti_plugin_unlock_bug
which comes back with jack ! ie Can’t be reached !! So that suggest there may be a Reaper Akai comms issue.

Some more thoughts while my brain is still active.

When you “opened” Akai in Reaper did you add it to the track via the FX “menu” ? Or did you use the add the “Add virtual instrument to new track” ? Some times the latter is a bit “wonky” I’ll open a new track and add the FX ie your Akai plugin to that track. May be worth a try to create a new track that way.

If you click on the tracks FX “button” and write Akai in the filter section, does it show multiple copies ? VST, VST2 VST3 ? I have found with some of my Waves plugins where there are multiple versions Reaper only works at the VST3 level ie if I load the VST version…nada !! Worth checking.

I’ll do some more digging in the morning, which should be mid evening for you. Hopefully we’ll get it sorted one way or another !

Cheers

Toby
:sunglasses:

Another friend suggested this video… (it’s short)

When I tried the first setting, Master Track set audio output, instead of the many options on the video, all I got was this

I did add it via the FX menu/button