Problems with the community on mobile

I’ve just done the same as @Mari63 and now have the desktop view on my iPhone. It seems to be working now and is no longer flashing. I’m not sure if I’m missing any mobile features now though.

How do you know if you have the desktop or mobile view on the app?

I’m not entirely sure, Stuart, I just used the address line in the link Jeff posted above that ends in mobile view =0 . The view in the main screen is different than before, the words are larger or something and it doesn’t seem to fit the mobile screen view you have to slide over a bit, but it’s usable.

Me neither.

I just tried to post from mobile and noticed all the formatting and photo insertion is missing.



To be honest I installed the app on my phone so long ago know I can’t recall the set up. I’m almost sure that I didn’t do anything apart from log in. Didn’t know you could get desktop or mobile views in the app.

It isn’t really an app. Just a link to the community website.

If you tap on the hamburger (three horizontal lines for menu) at the bottom right (on my iPhone) it has a link “mobile view” if you are currently in desktop. I forget what is says when you are in desktop, I am afraid to go into mobile view to find out. But something similar to “desktop view”.

1 Like

The only difference I seem to notice is that the formatting in desktop view is less optimal on my phone than the mobile view. It is just a little more difficult to read, a few things seem to overlap text and the biggest issue is that text in a long reply eventually falls behind the keyboard on my phone making it hard to edit mistakes. Manageable, but not a easy.

But, small things. I can still use my phone, and the overall function of the community site is still worlds better than many other forums I have experienced (that aren’t on Tapatalk, that works well, too).

I have just reported to @larynejg

Don’t do it … it commences with the flashing :face_with_symbols_over_mouth:

But using the link above sorted it out :kissing_smiling_eyes:

We’re looking into it! Sorry for the issue - but it seems to be caused by Discourse!

1 Like

Yes, hope you can sort this out. I’ve just been replying to some posts and the quoting, formatting etc is a mess when using an iPhone in desktop mode.

Discourse did an upgrade on their end last week which made a lot of browsers obsolete.
The Samsung browser on my old tablet is no longer supported so I had to switch to Chrome.
So it wouldn’t surprise me if most of the problems people are having is on the Discourse end.

So on my iPhone (latest iOS) I downloaded chrome and opened the community from there. Went to mobile view and got the dreaded flashing forum (DFF).

So, chrome vs Safari isn’t the issue.

That link from Jeff worked out for me… have Iphone.

Well I was having problems in replying and quoting than I saw this symbol >> on the right of the orange REPLAY button…and when I touched it anything fell into place. I have Android on my smartphone.

Whilst typing a reply to a post with my iPhone in desktop mode, it suddenly reverted to mobile view and started flashing and became unusable. I didn’t touch any settings, I was simply typing a reply.
I’m posting this using my iPad. Both my iPhone and iPad have the latest Safari browser.

Could it be that Discourse recognises the type of device you’re using and automatically changes the view to what, under normal circumstances, would be the better viewing mode? If that’s the case then the workaround view=0 thing won’t work long term.


For me (iPhone), I opened from the website directly which fortunately defaults to desktop view. Then I have saved a bookmark to my desktop, and it has retained the setting since.

I never tried the suggested irk command.

Mobile view is still broken days later… which selfishly means that I can’t use the community as much.

The workaround doesn’t work great, as replying, while possible is still ridiculously hard - the text box goes under the mobile keyboard.

Is it just me or has community usage also reduced with mobile not working?

Pleeeeeease fix this. Can’t believe it’s been days now.

1 Like

I have flagged it up again.