Sound issues Reaper to OBS

I’m having a sound issue when I try to record using my Focusrite through Reaper to OBS. If I record just into Reaper playback sounds fine or if I use the Katana to record everything sounds fine.

I know the simple answer is to just record through my Katana but curious minds need to fix this issue.

A couple of recordings to show you what I mean.

Thanks. :slight_smile:



1 Like

I know you’ve been at this far longer than I have but , as I have my head into reading up on recording, one thing I hadn’t expected was buffer size , if it’s to small you’ll get dropouts, basically what you heard there. I would suspect though that that isn’t the case.

Thats the only one I know of.


1 Like

What is the signal chain of each of the recordings, and are you on Windows? Are you using reastream from reaper to OBS?

Could be buffer size, could also be power management settings. Or maybe firewall/AV software.

1 Like

Hey Stefan,

Oh, the fun of OBS :rofl::sweat_smile:

Yeah mate, lots of permutations. Perhaps you can narrow down a few things for us.
How are getting Reaper’s output into OBS? Rearoute?
Are you getting a good recording straight from Reaper?
What are your audio setting in OBS?
Volume settings in the OBS mixer?
Is the problem on the recording only, or are you hearing it live?
Are other Windows audio apps/ devices deprioritised/ disabled?

Cheers, Shane


Thank you everyone for the replies and to answer the questions…

Machine is running Windows 10.
The guitar is going in to the Focusrite, then the Focusrite goes into the PC via USB or the guitar is going into the the Katana and then into the PC via USB.
Reaper is going to OBS using Rearoute.
Buffer size is just the default in both Reaper and OBS, or whichever one has the buffer.
A straight recording and playback into Reaper sounds fine, no dropouts.
I’ve not changed anything for the audio settings in Reaper but can do some screenshots when I get home if needed.
I’ve not changed any mixer settings in OBS. Again, screenshots can be done.
Issue only on the recording playback, sounds fine when I’m recording.
Nothing else running. I’ve tried it with just Reaper and OBS running.

I hope that helps.

Have you added ReaRoute1/ReaRoute2 to the Master track in Reaper ?
On the OBS ASIO Input Capture source, do you see the audio signal arriving and displaying in the Audio Mixer window ?


Toby, I’ll check your first question when I get home later* but to your second one, yes there is audio signal arriving in the mixer window and I can even increase/decrease the volume in there.

*I’m sure you know what it’s like when you have tinkered that much you cannot remember what is what anymore. :smiley:

1 Like

Sounds like buffer or sampling. Does the Focusrite have a control panel where you can change the buffer setting to match Reaper ?

What block size are you using ? I did have a similar issue a while back and had to up the Project setting in Reaper to 512 and within ASIO4ALL.

I know the screenshots show 256 but it was to show they should both match.


If you are running 256 or lower, try increasing to 512. You should still get decent latency.
At 512 I’m getting 16ms in/out to 32ms in total that is acceptable. Top right in Reaper window.


If going to 512 solves the issue but the latency is high/noticeable, give me a shout as Kenny has a tut on Latency offsets in Reaper but one step at a time.


Thank you for that Toby. I’ll have a look at it all a little later today.

1 Like


Just a thought. In case you are not sure how to check the ASIO driver setting for your Focusrite, if you click on the ASIO Configurations button in the Audio Device Settings window in Reaper (see above) it should open the associated dialogue box, as shown in the first screenshot (won’t be the same but something similar).


1 Like

Thanks Toby.

I’ve increased the block size to 512 but still having the same issue. Tried a different cable and another guitar as well, just in case.

Here are a couple of screenshots the the questions you’ve asked. It doesn’t look like Focusrite has any buffer settings.

Is the OBS sample rate also 44.1k ?

Something to check… :sunglasses:

1 Like

Just spotted the Scarlett buffer size is 192*. That needs to be the same as the Reaper block size. Increase that to 512 and see if it cures the issue (with OBS set to 44.1). If that works try them both at 256.


1 Like

I think because Stefan hasn’t ticked force setting it is not applying 512 buffer size, but using Scarlett’s default.

Stefan OBS settings would come in handy as well. I had the same issue in the past and can’t remember how I fixed it :see_no_evil: but seeing OBS settings might refresh my memory. I need to know

What audio input device you’re using in OBS
Which output you applied rearoute into
Have you muted down the input you are not using and to which you applied rearoute?

Main project settings in Reaper would be handy too


I have a gut feeling that when I used webcams audio driver and haven’t fully muted it down was the issue for me. When I swapped it for laptops inbuilt mic, went to windows sound settings and turned mic input to 0 it did the trick, but again can’t remember for sure.

1 Like

That means checking the “Request sample rate” box :sunglasses:

1 Like

Adi when using ReaRoute you don’t need to piggy back on another audio device like ReaStream, its effectively point to point. So it takes that particular curved ball out of the equations. But unlike ReaStream_standalone which can be used in any DAW, ReaRoute is specific to Reaper - as far as I know,

Exactly, by not checking it should be same as your interface’s setting. Unless there was something in main Project setting about sample rate and buffer size? On my phone now so can’t check :frowning:

Oh and I am using the one where you need to piggy it back onto other sound device - as it was working I decided to not fiddle with it anymore :grinning:

:rofl: :rofl: :rofl: :rofl: