Why if I try to open a URL in a received SMS, does it open the JustinGuitar app?

I have the Android version of the JustinGuitar app - 3.3.1

I have a Sony Experia I3312 and the operating system is Andriod 8.1.0

It is each and every time I try to open a URL in a received SMS message it opens the JustinGuitar app.

Could open URL’s before installing.


Hi @GeoffMolyneux

Thanks for getting in touch!

Is this when you already have the app open on your device or is this when you are simply opening a link in an SMS message that it loads the Justin app?

When I try to open a link from an SMS message. The JustinGuitar app is at that time closed.
Until trying to follow the link opens the app. @MusopiaApps


This is very odd!

Can you please send us a screen recording of the issue via the FEEDBACK button in the app so we can investigate this further? :slight_smile:

Android 8.1 does not make that easy…

I have made a video with another device looking at screen, too large to attach here. I could email if it might help ?

Hi @GeoffMolyneux

Not to worry, if you can send some screenshots instead of a screen recording that would be really helpful for us to send on to our developers :slight_smile:

Out of interest, have you tried uninstalling the JustinGuitar app?

Doe the behaviour go back to normal if you do?

And then, does it break again when you reinstall the JG app?



I had not tried as thought I would “lose position”.
But tried as suggested and wanting to fix.
Though some might say the phone always just opening JustinGuitar whatever else you were trying to do is just fate and accept it and go practice or learn… :smiley:

Yes it did.

No - seems to work now, thanks for persuading me to try… :smiley:


1 Like

I’m glad it worked!

Within Android (in most OSs in fact) there’s an association held between certain file types and activities so that the OS knows what to do when a file is opened, a link is clicked, and so on.

This can be used, for instance, if you have multiple web browsers installed (Chrome, Firefox, etc.) in order to select one as the default.

It sounds, to me, that this setting somehow got messed up on your phone and ended up pointing at the JG app instead of the web browser. There’s manual ways to set this, but the easiest way is to remove the JG App which then resets that association back to normal (probably pointing at Chrome).

I have no idea what caused the association to get messed up like that, but I would be very surprised if it was the JG app itself.



1 Like

Glad to hear you are back on the app without any issues @GeoffMolyneux and a huge thank you to @Majik for your troubleshooting advice :muscle:


Like Windows opening certain file types with a specified program, I had look after a Google before starting this thread, but found nothing. Thanks !

1 Like